Release: 15.5.3 Servicing Release

We are publishing a servicing release for our current major release called 15.5.

Please check out the product release notes to see all the fixes and known issues for this release.

Bug reports are welcome. If you see any new issue with these versions, please file a report.


Products Released


Included Fixes

This release focuses on a few issues from the Xamarin 15.5 release:

  • Bugzilla 60625 [Xamarin.Android, Xamarin.iOS, Xamarin.Mac] – “Assertion at … local-propagation.c:562, condition `ins->opcode > MONO_CEE_LAST’ not met” in apps that use strings in fixed expressions if compiled with a recent version of Roslyn.
  • Bugzilla 60963 [Xamarin Profiler] – “Sorry, something went wrong trying to run … Runtime installed on device … is too old” when attempting to profile Android applications on API 26 (Oreo 8.0) (and newer) devices and emulators .
  • [Xamarin Profiler] – iOS apps get launched on both the Remoted iOS Simulator and the non-remoted simulator when the Remoted iOS Simulator setting is disabled.
  • [Visual Studio Tools for Xamarin] – Visual Studio crashes due to a UI exception in some scenarios when using the Xamarin.Android Archive Manager.
  • [Visual Studio Tools for Xamarin] – Update the project templates to the latest version of Xamarin.Forms.

Installing


Previous Versions

Using the latest versions is recommended. The previous versions of the Xamarin packages from the Xamarin 15.5.2 release are listed below for reference.

  • For Mac the previous versions are: